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Protocol for Leaf  Image Analysis – Surface area (although other measures could also be made) 
 
Image Capture of Leaves 
 
1. Take digital images of leaves arranged on a very white background (like foamboard) in very bright 

lighted conditions.  Use plastic film (heavy, buy at art supply) to cover leaves, or make a wooden 
frame with non-glare clear plastic for top.  Leaves will lie flatter if slightly wilted and turned bottom-
side up.  If in sunlight, try to minimize glare and shadows by photographing in indirect sunlight, 
however, this is not as essential as very bright conditions.  If indoors, halogen floodlights (or 
equivalent) will be needed. 

2. Images can be JPEG, TIFF, or other format. 
3. Lay leaves out around a reference of known size (I used the smallest Post-It note; blue seemed to be 

the best with leaves).  This will serve as your reference for calculating area with the reference’s area 
as the scale, divided by its actual area.  The smallest Post-It is 37x51 mm, 1887 mm2.  The reference 
should be in the middle and no overlap of leaves and/or reference. 

4. If using more than 4 cherry leaves (big leaves), you will have to also have the same references at all 
4 corners to check for distortion.  If you want to have a larger set of leaves, you will have to be further 
away from the leaves for photographing (longer focal length), but still zoom in as much as possible to 
exclude extraneous surface, etc. 

 

 
Example of digital image taken under halogen lighting of 4 cherry leaves arranged around a Post-
It note for size reference (no cover so note is not lying flat); holes in leaves will be included in 
area estimation (see instructions that follow). 
 

5. Develop an order for photographs so that labels don’t have to be used in the photographs.  I used the 
following sequence: 



  

a. Orchard 
b. Rep 
c. Treatment 
d. Type of sample (shoot leaf, next sequence was spur leaf) 
e. For 10 leaves I shot 3 photos—2 with 4 leaves each, 1 with 2 leaves 

Using this sequence, I moved through the reps, treatments within reps, and the leaf type in order, thus 
always can identify what image goes with what in the total group. 

 
Also, this means that as long as you keep everything in this order, you don’t have to put the individual 
photo files into file folders (in the computer) except by orchard and you can move through the analyses 
easily, either as single images or as a ‘stack’ analysis. 
 
I have compared Image J software (free from the NIH website) and Digimizer, which you can get on a free 
trial basis before purchase.  Digimizer is easy to use, but without much power compared to Image J. 

Digital Image Analysis Software -- Download ImageJ 1.4.1a (current as of May 4, 2008)  bundled with 
Java 1.6.0_05 for Windows from   

http://rsb.info.nih.gov/ij/download.html 

Documentation is very useful 

ImageJ – you can either analyze images one at a time or as a ‘stack’ if all are taken at the same focal 
distance, thus no adjustment needed for the size of the reference value in each. 

Single image analysis with Image J (not by stack analysis):  

Drop down menu titles shown underlined and bolded 

1. File → Open…open the first image file in the consecutive group that are from the whole orchard or 
whole set that you are tracking as a ‘given group’.  The directions that follow here are for the first file, 
then the rest of the files do by the next set of instructions. 

2. If your image includes problem areas, like edges off your photos, shadows, unwanted fringe material, 
you can now Crop your image y dragging the Rectangular tool on the far left of the lower toolbar, then 
going to Image → Crop 

3. Image → Type → 8 bit (this is grayscale and can be used with stack analysis also if saved as a new 
image) 

a. Image → Adjust → Threshold  (to get red leaf images) 

b. Drag the lower slide bar back and forth to get a minimum amount of red in the background and 
minimum gray in the leaves and reference Post-It image 

c. ‘Apply’ and you will now have a B&W image 

http://rsb.info.nih.gov/ij/download/win32/ij140-jdk6-setup.exe
http://rsb.info.nih.gov/ij/download/win32/ij140-jdk6-setup.exe
http://rsb.info.nih.gov/ij/download.html


  



  

Optional -- Process → Noise → Despeckle.  Specks don’t have to be deleted from the background, nor 
do holes in the images because they can be adjusted for with the image analysis 

4. From Analyze menu, go to Set Measurements and check Area, Std. Deviation, Display Label and 
change the Decimal to ‘1’.  You can also choose to Redirect to a given file, if you wish. 

  



  

5. Go to Analyze Particles and set the range appropriate to get the minimum ‘area’ calculated for the 
smallest leaves and/or the reference.  This is a step you will need to do when you first work with a 
given kind of leaf (or other object), and/or reference for size, so that you can exclude little bits of stuff 
that collect in the field of view.  I have found that setting this to 10,000-infinity works for cherry leaves 
and post-it notes. 

6. Check Display Results and Include Holes. 

7. All your measurements will go into a ‘Results’ file in its own window, which you can either copy and 
paste into an external Excel spreadsheet, or wait until the very end of your image analyses and do it 
at one time. 

a. You will be asked if you want to ‘Save results’.  You can—in which case you will have to 
name the file and choose a location; or you can say ‘no’ and view the results. 

b. You will get results that look like a spreadsheet (but it is actually a *.txt, or ‘text’ file, 
despite choosing *.xls as a file extension).  You can either save this, or highlight, copy 
and paste into a spreadsheet.  You will probably get a message that it isn’t an Excel 
format if you try to open a saved file with Excel, but just open it as a ‘delimited text file’ 
and you will be fine. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8. Do not close this first image file.  Here follow instructions for all the rest of the consecutive 
image files. 

9. File → Open next   You can also use the keystrokes: CTRL + SHIFT + o (the letter ‘O’) to open the 
next file.  The very next image will open, after you’ve been asked if you want to save the image with 
its changes.  DON’T CHANGE THE PARENT FILE!. 



  

You will not have to do all the steps above as some of these are now saved.  Do only the following for 
each subsequent image, without closing the previous one as shown in #10-on. 

10. Image → Type → 8 bit  

a. Image → Adjust → Threshold.  Here you can either use the ‘Red’ default or choose ‘Black and 
White’ from the drop-down menu. 

b. Drag the lower slide bar back and forth to get a minimum amount of red (or black for the second 
option above) in the background and minimum gray (or white) in the leaves and reference Post-It 
image 

c. ‘Apply’ and you will now have a B&W image 

11. Analyze → Analyze Particles and you will now get the new results, which you will highlight, copy 
and paste into your ‘Results’ spreadsheet from the first image file.  Do not worry that the numbers in 
the first column will repeat over and over again, as this will be fixed when all the results are in.  Save 
your Results spreadsheet each time if you want to ‘play it safe’! 

12. Go on to the next image file, without closing each one other than when asked if you want to save the 
changes.  All the parameters will be saved and you can go through all the files consecutively this way. 

 

Steps to evaluate multiple images at once (the stack method):  You can do this if you have taken all your 
photos at the same focal distance without changing your reference size. 

1. From File drop down menu, select  
a. Import → Image Sequence:  First choice, fastest, but if there is a lot of difference among photos 

with glare, etc, this may not be as good as other choices.  Worked for photos taken indoors under 
floodlights, but not good for outdoors with glare on plastic sheet, reflections, etc. 

b. Open → for choosing individual files for greater precision of manipulation.  Using this option, you 
can manually select one or more images, holding down the ‘Shift’ key and highlighting those you 
want to include.  You can then choose a group (like 3 images making up a set of Rep-Treatment-
Sample Type = 10 leaves from a single tree).  This is better for tracking threshold variation (see 
later), and grouping to keep track of what is what. 

c. If using the Open option, you can use Open next for subsequent images so you don’t have to 
keep track of what you have already processed—but you will have to keep the previous image file 
open.  The program will close it for you once you have chosen to save the changes or not. 

If you chose the first option:  
2. Click on desired file to open it, then on first picture file in the folder, and Open.  Wait until all images 

load (see progress slider in lower right corner of box and tally of images being imported in lower left 
corner). 

3. A pop-up window called Sequence Options will appear, showing how many files are in the selected 
folder, starting with Image 1 and increments of 1, scale 100%.  √ the boxes for Convert to Grayscale 
and Sort Names Numerically.  Check Ok 

4. Save As → Tiff file in the folder with the images (wait until all are saved in this single big file).  Using 
the ‘Tiff’ format you can open this file in the future if desired to run other analyses.  However, if you 
don’t want to use Grayscale images in future, you will have to use the native image files. 

5. From Image drop down menu, select Adjust→ Threshold 
a. In the drop down menu at the bottom, select Black and White 



  

b. You should drag the top and bottom sliders some right and left, to see how this cleans up the 
image or introduces more noise.  It will be different for each image, so for greatest precision, 
you may have to open each image separately. 

c. Click Apply 
d. If you imported a sequence of images, A pop-up window will ask if you want to Convert all images 

in stack to binary?  click OK. 
6. From Process menu, you can choose to: 

a.  remove Noise by Despeckle.   You can also remove Outliers here, playing around with the 
Pixels and Threshold settings.  Be sure to use Dark and Preview.   I found that if you set the 
parameters higher than 10.0 for ‘Pixels’ and 100 for ‘Threshold’ you will eliminate the leaf stems. 

b. Remove holes by using Binary submenu and Remove holes.  However, you can skip this and 
do it with the Analyze Particles process (see later).  You can also choose to make the image 
Outline here, but I have found that I tend to get higher std. deviation using outlines as opposed to 
a solid black image for the Particle Analysis (see step 8). 

7. From Analyze menu, go to Set Measurements and check Area, Std. Deviation, Display Label and 
change the Decimal to ‘1’.  You can also choose to Redirect to a given file, if you wish. 

8. Go to Analyze Particles and  
a. set the range appropriate to get the minimum ‘area’ calculated for the smallest leaves 

and/or the reference.  This is a step you will need to do when you first work with a given kind of 
leaf (or other object), and/or reference for size, so that you can exclude little bits of stuff that 
collect in the field of view.  I have found that setting this to 10,000-infinity works for cherry leaves 
and post-it notes. 

b. Check Display Results, Include Holes.  You shouldn’t need to do this for subsequent images.  
You may need to exclude shadows, edges of the foamboard, or separate overlapping/touching 
objects.  Use the ‘drawing tools’ to do this, but whatever you select (whether with the ‘freehand’ or 
‘rectangular’ tool, etc, that will be the image that is analyzed.  You will then have to go back and 
do the others, or do all and then go back to the 1 or 2 you need to ‘clean up’.  You can ‘crop’ 
doing this, but if you have more than 1 image open as a sequence, you will do this to all 
and most of these changes can’t be undone. 

c. You will be asked if you want to ‘Save results’.  You can—in which case you will have to name 
the file and choose a location; or you can say ‘no’ and view the results. 
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